Couldn't load XPCOM

Опубликовано mensh - вс, 06/12/2011 - 07:15

На свежеустановленном Arch Linux с kernel-2.6.33.4 (ядро обновлять нежелательно — старое железо) не запускается Firefox 4.0.1. Появляется сообщение:

...
Couldn′t load XPCOM.
...

Подобное обычно происходит при обновлении и лечится в одних случаях так:

$ sudo pacman -S xcb-util cairo

в других так:

$ sudo pacman -S xulrunner

или так:

$ sudo pacman -S libevent

В данной ситуации проблема решилась следующим образом:

$ sudo pacman -S gcc-libs

в результате чего были обновлены следующие пакеты:

...
upgraded linux-api-headers (2.6.33.2-1 -> 2.6.38.1-1)
upgraded glibc (2.11.1-3 -> 2.13-5)
upgraded gcc-libs (4.5.0-1 -> 4.6.0-6)

Запустился и Conkeror, не работавший до этого по той же причине.